Lokalisierung in Office365

Und mal wieder eine (Erfolgs)Geschichte aus Office365 … also ich habe da so eine Mysite unter busitec-my.sharepoint.com. Die Mysite wurde ursprünglich in Englisch angelegt, und anschließend habe ich die Sprache auf “Deutsch” umgestellt.

site_setting_locale

Wenn ich nun einen Blog anlege, dann ist der zunächst auf Englisch; kein Problem. Also Sprache auf Deutsch umstellen. Sieht ja alles Super aus – alles läuft; oder etwa nicht? Wenn ich nun in “Beiträge verwalten” gehe und mir alle Beiträge der Liste anzeigen lasse und dann einen einzelnen Beitrag anklicke …

post_error

Wow! Was ist denn das? Eine Fehlermeldung, und das bei O365? Wie kann denn das … und viel Interessanter ist ja noch, wenn ich den Beitrag direkt von der Startseite aus aufrufe, dann geht’s?!

OK – die Erklärung ist dann doch ganz schnell gefunden. Wenn ich den Beitrag von der Startseite aus aufrufe, dann sieht die URL wie folgt aus:

https://busitec-my.sharepoint.com/personal/eiben_busitec_de/Blog/Lists/Posts/Post.aspx?ID=1

Wenn ich aber über die Liste der Beiträge gehe und dann auf den Titel klicke wird diese URL aufgerufen:

https://busitec-my.sharepoint.com/personal/eiben_busitec_de/Blog/_layouts/15/listform.aspx?PageType=4&ListId=%7B36A2AAFB%2D5143%2D403F%2DA325%2DA7610CDE8EA6%7D&ID=1&ContentTypeID=0x01100007A0E26C347C5F4899398346B0DAF58B

…die dann einen Redirect auslöst auf:

https://busitec-my.sharepoint.com/personal/eiben_busitec_de/Blog/Lists/Beitraege/Post.aspx?List=36a2aafb%2D5143%2D403f%2Da325%2Da7610cde8ea6&ID=1&Source=https%3A%2F%2Fbusitec%2Dmy%2Esharepoint%2Ecom%2Fpersonal%2Feiben%5Fbusitec%5Fde%2FBlog%2FLists%2FPosts%2FAllPosts%2Easpx&ContentTypeId=0x01100007A0E26C347C5F4899398346B0DAF58B

Hier wird also die URL lokalisiert Smile ist zwar nett von SharePoint, dass er so viel wie möglich lokalisieren will – aber bitte doch nicht die URL. Denn eine Liste Beitraege gibt es nicht. Die würde es nur dann geben, wenn beim Anlegen der Site auch “Deutsch” ausgewählt gewesen wäre. Dann würde SharePoint die Namen der Listen an die Sprache anpassen.

Interessant ist IMHO, dass das listform.aspx (welches für den Redirect zuständig ist) nicht erkennt wie die Liste mit der ID 36A2AAFB-5143-403F-A325-A7610CDE8EA6 wirklich heißt.

Nachdem ich ja nun schon vor 3 Wochen einen Fehler in Nintex beim Auflösen von Gruppennamen und letzte und diese Woche einen Fehler in ShareGate beim kopieren von HTML-Inhalten gefunden habe, werde ich diesen Fehler auch mal versuchen an Microsoft zu melden – immer muss man alles selber machen.

3 Comments

  1. Hallo,

    das ist auch bei SharePoint 2013 on premise so. Haben Sie mittlerweile eine Lösung für das Problem gefunden?

    Ich dachte erst dass man hier den Blog mehrsprachig gestalten kann, im Sinne der Variations, doch leider geht das nicht.

    Reply
    • Ich war dem Problem ja in O365 begegnet – inzwischen hat dort ja schon mehrfach der Update-Gott zugeschlagen und das Problem wurde mit einem Update behoben. Seit wann kann ich nicht genau sagen, man bekommt die Updates in O365 ja nicht mit – und welche Version genau dort gerade läuft ist ja auch nur bedingt zu erkennen. Also aktuell läuft unsere Tenant mit der Version 16.0.0.1218 – was das auch immer an CU bedeutet.

      Reply
      • Dann wird es für die on premise Version noch keinen Patch geben, denn wir haben das SP1 installiert und dort ist es noch genau so, leider.

        Reply

Kommentar verfassen

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.